Importing GPS Coordinates

In this Chapter you will learn

ISTC Topic:

e How to add an Excel spreadsheet with XY coordinates to your map
e How to convert Degrees-Minutes-Seconds into Decimal Degrees inside ArcMap

1. Importing XY Coordinates

While many Global Positioning Systems (GPS) have cables that will automate the process of
importing coordinate data, you may still be faced with a table displaying coordinates and the
associated attributes. This chapter will show how to bring in those tables and display the data on
your map in the correct location.

Exercise 1: Importing an excel spreadsheet with decimal degree coordinates

1. Open ArcMap and start a new map document. Add the Counties shapefile from the Topic10.3

folder. — =]
2. Click the Add Data button again and browse to the Topic10_3 ERIR AL -
folder. Double click on the Decimal_Degrees.xls spreadsheet to Sheetl§
expose the three worksheets in this Excel file. Then click once on e b e S
. « ”» ¥ | Benewah -118.791102 | 47.225541
Sheet1$ and click “Add”. Monteview | -112.538518 | 43939934
Rexburg -111.793896 | 43.828739
3. Open the spreadsheet (right-click and then choose open). You Arco -113.308738 | 43.637331
. . s . . . Nampa -116.564263 | 43.580513
can see this table contains 7 cities in Idaho along with their Murphy 116558053 | 43.219616
coordinates in decimal degrees. Notice that NAD83 X is a Heyburn -113.763848 | 42.563141
negative number because we are on the western hemisphere. — 1 o[BS
The coordinates are given in latitude and longitude so we know 0 out of 7 Selected)
Ot O elecie:
we are dealing with a Geographic Coordinate System (as opposed Sheetls
e
to a Projected Coordinate System). The heading of the fields let us
know that the NAD83 datum is used. 2] Sheet
& Open

4. Close the table. Then right-click on the spreadsheet again and
choose “Display XY Data ...” as shown on the right.
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Follow the directions below to add the data to your map as events.

(" Display X¥ Data [ | [ spatial A ] . ] [ spatial Reference Properties [
: 4. Double-click on “Geographic
A table containing X and Y coordinate data can be added to the X Cod . » XY Coordinate System
map 25 a layer Coordinate System |
Choase a table from the o) . Tp— - l Ly _’ ~ | Typehere to sear] . .
pmemetnret L Set X Fleld & e oo 6 Click on NAD 1983.prj
Sheefl$ to NAD83 X cilfi| Geographic Coordinate Systems| © NAD1927
Specify the fields for the X, - —_— \:. g :rujer.ted Coordinate Systems & NAD 19 .e?::mi’on 1976)
X Field: NAD83_X - = cly;:m ] NAD 1063
: - © oTve3 €3 NAD 1983 (2011) 3
¥ Fiekd: - 8 NAD 1983 (CORS96)
NAD 1883 (C5RS)
ZField: <None> /v (& NAD 1983 (NSRS2007)
. &3 NAD 1983 HARN u
Coordinate System of Inpu 2 Set Y Fleld L] =028

Current coordinate system:
Desaiption: to NAD83Y — - = GCS_MNorth_American_1583 n
Projected Coordinate System: = Spatial Reference Properties. WIID: 4269 Authority: EPSG
Name: IDTM83 XY Coordnate System | Angular Unit: Degree (0.0174532925199433)
) Prime Meridian: Greenwich (0.0)
Geographic Coordinate System: g
Neme: GCS. Nor th_American. 1963 A B rer— AR @ Dﬁwﬂ;ﬁg‘jgm'm]
A ype here to searc PR ‘Semimajor Auds: 63781370
— ‘Semiminor Axis: §356752.314140356
/ ) Antarctica o Inverse Flattening: 298,257222101
@ £ Asia —
PR - ¥ 3 Atlantic Ocean .
3. This is the wrong - o B Aumtnmanenzend 5. Double-click on 7 Click “OK”
. ® £ Caribbean . i
coordinate system. 5 3 Couny Systems “North America”
Cl' k led't" ® [ Eurcpe |
ic i ] Eur
_— - restricted functionalty | g
About adding XY data o ] [ cama ] S Resite feen - -
8. Click OK
.
Table Does Not Have Object-ID Field (o]

The table you specified does not have an Object-ID field so you will not be able to .
select, query, or edit the features in the resulting layer, or define relates for them. 9 Igl’lOl"E the warmng about the
After you create this layer, you can export it to a shapefile or feature class if you Ob]eCt—ID field because we will EXpOl"t

need these functions. To export a layer, right-click it in the Table Of Contents and datato a Shapeﬁle later on. Click OK
choose Data>Export Data. Add the exported data to the map as a new layer.

[ OK ’] I Cancel ]

6. Sheetl$ Events have now been added to the table of contents
in your map. If all went well the points representing the
various cities in the excel table should now appear in their
correct locations on the map.

7. Events only exist within this map document. To preserve this
data and make it available for use in other map documents it
is wise to export the events into a shapefile. Right-click on
Sheet1$ Events in your table of contents and click Data >
Export data. Save all features in a new shapefile called
“Decimal_Degrees” in the Topic10_3 folder.
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rcise 2: Converting Degrees-Minutes-Seconds into decimal (f— )
degrees
i Failed to connect to database.
1. Open a new map. Click the Add Data button and open the An underlying database error eccurred.

Class not registered

Degrees_Minutes_Seconds excel spreadsheet. You will see the error
on the right because this excel file is in the .xlsx format. Hopefully
in future releases of ArcGIS you can import .xlsx files, but for now

we need to convert it in .xls.

2. Close ArcMap and open Degrees_Minutes_Seconds.xlsx in Microsoft Excel. Take a look at the
formatting of the coordinates in this table. You can see that the X and Y coordinates have been
separated into degrees, minutes and seconds. In addition the X coordinate is not a negative
number, instead the table includes a column called “X_DIR” to indicate that the location is in the
western hemisphere.

3. Click File > Save As shown below. Then close MS Excel.

Click the drop-down box and

choose Excel 97-2003
Workbook (*.xls) \
File name: Degrees_Minutes_Seconds.xlsx

Save as type: | Excel Workbook (*.xisx) x

Excel Workbook (*.xlsx)
Excel Macro-Enabled Workbook (*.xlsm)

Excel Binary Workbook (* xlsb)
Excel 97-2003 Workbook (*xls)

XML Data (*.xml)

Authors:

4. Start ArcMap again and open a new map document. Bring in the Counties shapefile as well as
Sheet1$ of the Degrees_Minutes_Seconds.xls you just saved. You should not get any error
messages this time.

5. Open the Sheet1$ in ArcMap. Unfortunately, the coordinates are not in a format you can import.
So, we will compute the decimal degrees and then import those. First we need to export the
table to DBF format and then create two new fields in the table, one for the X coordinate in
decimal degrees, and the other for Y coordinates. Finally we need to compute the decimal
degrees from the information we have.
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Use the instructions below to export the excel table to .dbf format.

1. Click drop-down box
and choose Export

2. Exportall records - =)

Export Data

i |[ co: i D[ ([ e JemaiE-lslacs

]
By seect By Atributes.. n,mmls, 2: ’;:,. v,nenasg‘:, iNv,M | r,mn‘; l;,’sf:;s Use the same coordinate system as: 1 "
e e o — T 4. Browse to
e T | e | Intermediate folder
Tun i O ] sssrrs aln w [ I iy apphes o export 1 & festre Gataset in a geociatzbase) |
[] Show Field Aliases 5 OCutput table: -
e ot o[ cesme] 3 Click on the 5. Name table
“ Restore Default Column Widths . = @« . ”
Restore Dt i e folder icon Degrees_Minutes_Seconds
Joing and Relates » ! |
Lg\aned:full: v Lo= Degrees_Minutes_Seconds 1 [ sge |
dly Creste Graph... Saveas type:  [JASE Table = ca
S 50 = | L
O Reload Cache I § 1 — —
3 rin ] —
- e , 6. Use drop-down box to 7. Click
— 8. Click OK save as dBASE Table “Save”

7. When prompted add the new .dbf table to your map. Right-click on the Excel spreadsheet and
click remove. Open the dbf table and use the instructions on the next page to add two new
fields.

1. Click drop-down box

i el ? )
- and choose Add Field... Ad Field == 2. Name the new
T tone: pec X field “DEC_X”
B Find & Replace... || Tre: Double =
Bl Select By Attributes... X_DIR x_Mm;s; 12?_%:%8 v_neanes:s; :v_un -4-_|um£z ;E_T:;EGZEZ: i et h\ 3 Set Data Type tO
By Switch Selection W :: :?323; :: : ;s‘; ::;3?5.; [ Precision [12 ] Double Wlth a
[ selectan 3| 5134716 Al 34 [ 48647412 (Scak e ] P igi f12 d
Add Field... 33 | 28.989108 43N 13 [ 10616232 reCISlon O an
Tumn All Fields On W 45 | 49.852116 42N 33| 47.307024
[v] Show Field Aliases e a Scale 0f8
Arange Tables ' | 4. Click OK |
" Restore Default Column Widths
1 i . . [Fi i ]
8. Repeat the instructions 1. Right-click on DEC_X and EEHER L9 et
. Parser
above to create second choose Field Calculator o Python
. « » X . 3 inctions:
field called “DEC_Y” that L | e T sk
. 0 = ndin e O‘N’u“bﬁ
is also a Double with a = iy o o i
d———————|F sontDescending CITY_NAME ) string ExDH
Precision of 12 and a —] See R 1o =0
Scale of 8. — AT ares sn()
Field Calculstor... I Y_DEGREES Tan ()
9. Use the instructions on Dheden 2o u”’m .
‘urn Fiel Show Codeblock =
the right to use the field P Freeserunfreeze Column beC X - = Eio
X Delete Field [X_DEGREES] + [X_MINS]/60 + [X_SECS]/3600 n
calculator to compute X P —

in decimal degrees. 2. Construct equation:
[X_DEGREES] + [X_MINS]/60 + [X_SECS]/360

o

3. Click OK




. Also use the field calculator to compute DEC_Y = [Y_DEGREES] + [Y_MINS]/60 + [Y_SECS]/3600

11. Look at the results in your table. Notice that all the DEC_X coordinates have a positive value. If
you add those coordinates in this format they will land somewhere in China. Right-click on
DEC_X again and open the field calculator. Compute DEC_X = -[DEC_X] to make all the longitudes

negative, and thus located on the western hemisphere.

12. Right-click on Degrees_Minutes_Seconds.dbf in your table of content and choose Display XY
data. Make sure you set the coordinate system to Geographic Coordinate System > North

America > NAD 1983.prj.

13. Export the events as a shapefile called “Degrees_Minutes_Seconds.shp” in your Topic10.3 folder.

Exercise 3: Bringing in Mystery Coordinates

1. Open anew map document in ArcMap and add the Counties shapefile. Then add Sheet1$ of the

City_Coordinates.xls excel spreadsheet.

2. Open the excel table and notice the X and Y attributes. To import this data you need to know
what coordinate system the data is projected in. If this data was collected by a GPS unit, then
you would look at the setting on this GPS unit to find out what coordinate system was used to
generate the coordinates. Sometimes, especially if the data was collected by someone other than
yourself, you simply do not know. That is when you use trial and error to find out. Table 1
below lists some common coordinate systems used in Idaho.

Name Where Used Units Path to Projection
NAD 1983 Idaho TM State Meters Projected Coordinate Systems > State
Agencies Systems > NAD 1983 Idaho TM (Meters)

NAD 1983 StatePlane Idaho East Eastern Feet Projected Coordinate Systems > State
Idaho Plane > NAD 1983 (US Feet)

NAD 1983 StatePlane Idaho Central Feet Projected Coordinate Systems > State

Central Idaho Plane > NAD 1983 (US Feet)

NAD 1983 StatePlane Idaho West Western Feet Projected Coordinate Systems > State
Idaho Plane > NAD 1983 (US Feet)

UTM Zone 11 Western Meters Projected Coordinate Systems > UTM >
Idaho NAD 1983

UTM Zone 12 Eastern Meters Projected Coordinate Systems > UTM >
Idaho NAD 1983

Geographic Coordinate System North Degrees  Geographic Coordinate Systems > North

(Latitudes and Longitudes) America America > NAD 83

Table 1. Most commonly used projections in Idaho.




The data in your excel table is collected in one of three following coordinate systems:

e UTM Zone 11
e NAD 1983 Idaho TM
e NAD 1983 StatePlane Idaho Central

4. The challenge for you is to find out which of those three coordinate systems is the correct one.
Use trial and error to find out: when adding XY data, set the coordinate system to one of three
listed above and see whether your cities “fall” in the correct location inside Idaho.

5. After you find the correct coordinate system export the data as City_Coordinates.shp in your
Final folder.

2. Common reasons why you are unable to import an Excel table

There are two common reasons why you may not be able to import an Excel file. The first one, as
we have seen in exercise 2, is that the Excel file is in a newer version and has an .xIsx extension. You
solved this problem by opening the spreadsheet in Excel and saving it as an Excel 97-2003
Workbook (*.xls).

Cities In 1daho You can only The second reason is a not-
2 CTy NavE X v haveonerow /1y formatted Excel

1 \\\/Benewah 2288722 1784676 with headers table. Two common
2 Attribute name can petee formatting errors are
z not be blank 1::23:; shown in the figure on the
5 Nampa 2292966 1378702 left. Correct those errors in
6 Murphy 2292237 1338604 Excel and then try adding
7 Heyburn 2519384 1262555 the table to ArcMap again_




